Ошибка "Headers and client library minor version mismatch"

Дата публикации: 31.07.2014

 

При совместном использовании MariaDB 10.0 и PHP-5.4.4 с расширение mysql-* возникает ошибка:

Warning: mysql_connect(): Headers and client library minor version mismatch. Headers:50162 Library:50524

 Наилучшее решение - переходить на PDO, но поскольку ЮМИ пока этого не сделала, то два обходных пути:
1. Установить модуль php5-mysqlnd (при этом php5-mysql будет автоматически удален). Наилучший способ, я его пробовал

aptitude install php5-mysqlnd

2. Временно понизить уровень вывода ошибок в /classes/system/subsystems/database.mysqlConnection.php в методе open внутри блока try. Общая идея как показано ниже:

 


$err_level = error_reporting(0);  
$conn = mysql_connect('params');  
error_reporting($err_level);

Естественно, ошибка видна только при включенном выводе ошибок.

Источник http://dev.mysql.com/downloads/connector/php-mysqlnd/